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1 INTRODUCTION 
SAC-HOBI Tools is an Add-In for Microsoft Excel that loads, processes and 

displays data from the in-situ hyperspectral radiometer/logging system custom-built for 
SAC by HOBI Labs.  Integration of these software functions into Excel provides a 
simple, familiar GUI while providing direct access to Excel’s powerful analysis and 
display capabilities.  Further, it enables users to experiment with and modify the 
algorithms used for deriving secondary parameters, using familiar Excel formulas. 

1.1 System Overview 
The system as a whole and its components are described in detail in the System 

User’s Manual.  Here we describe it briefly as it relates to this software. 
The in-situ system consists of 
• Four HydroRad radiometers measuring seven optical quantities: 

o Downwelling surface irradiance (ES)
o Subsurface downwelling irradiance at three depths (Ed1, Ed2, Ed3)
o Subsurface upwelling radiance at three depths (Lu1, Lu2, and Lu3)

• A fluorometer measuring 
o Chlorophyll fluorescence 
o Turbidity 

• A three-axis magnetic orientation sensor measuring  
o Tilt 
o Roll 
o Magnetic heading 

• A HydroDAS logger/controller that governs the operation of the sensors, 
archives their raw data, processes the raw data, and sends processed data to its 
console port for transmission to shore via satellite. 

1.2 Data Processing Steps 
Data from the system undergo three major stages of processing: raw data archiving, 

primary processing, and derivation of secondary data, or post-processing.  Archiving is 
done only in-situ, by the HydroDAS.  Primary processing is performed both in-situ and 
by SAC-HOBI Tools.  Post-processing is performed only by SAC-HOBI Tools. 
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1.2.1 Raw data archiving  
Raw data are collected from individual instruments under the control of the 

HydroDAS, and stored on its hard disk in one file per instrument, with the file name 
extensions shown in the following table. 

HydroDAS archives data into one file per instrument per day.  The base name of 
these daily files is the four-digit year, followed by the three-digit day number, of the date 
on which the data were collected.  For example, on the last day of 2006 the archive files 
would be named 2006365.TLT, 2006365.FLR, 2006365.HR1, etc.  

 
File name extension File contents 

.TLT Raw tilt, roll and compass data 

.FLR Raw fluorometer data 

.HR1 Raw data from HydroRad #1 (measuring Es)

.HR2 Raw data from HydroRad #2 (measuring Ed1 and Lu1)

.HR3 Raw data from HydroRad #2 (measuring Ed2 and Lu2)

.HR4 Raw data from HydroRad #2 (measuring Ed3 and Lu3)

1.2.2 Primary Data Processing 
Primary processing can be done both by the HydroDAS firmware, and by SAC-

HOBI Tools.  It consists of the following steps: 
• Calibrations are applied to raw HydroRad spectra, converting them to 

radiometric units; 
• Average and maximum tilt (and heading) are calculated for each spectrum; 
• Spectra within the tilt limits are averaged together (time-averaged); 
• Time-averaged spectra are spectrally averaged  within user-specified 

wavebands; 
• Processed data are saved in a binary “.OUT” file; 
• The file is transmitted to the console port. 
When this processing is performed on the HydroDAS, the resulting binary .OUT 

file is archived along with the raw data files, with the same base name as the raw files.  
For example, the archived files for the last day of 2006 would include a file called 
2006365.OUT that contains all the processed binary data generated on that day.  SAC-
HOBI Tools can load, display, and post-process such files, as well as reprocessing raw 
data sets.  SAC-HOBI Tools does not generate .OUT files, but stores reprocessed data 
directly into Excel workbooks in the same format as if they were loaded from .OUT files. 
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Primary processing in SAC-HOBI Tools is explained in section 4.2.  Details of the 
processed data files are explained in the System User’s Manual. 

1.2.3 Secondary processing: Derived quantities 
In addition to duplicating the processing capabilities of the HydroDAS firmware 

(with some enhancements), SAC-HOBI Tools provides derivation of secondary quantities 
from the primary processed data.  These derived quantities are: 

• Water-leaving radiance (LW)
• Normalized water-leaving radiance (LNW)
• Remote-sensing reflectance (Rrs)
• Attenuation coefficients (Kd and KLu)
• Chlorophyll concentration extracted from radiance 
The algorithms for some of these, especially the normalized water-leaving radiance 

and chlorophyll concentration, are the subject of ongoing research and debate.  Therefore 
we have designed SAC-HOBI Tools to permit SAC researchers to modify and 
experiment with them within Excel.  Details are explained in section 5. 

1.3 Charting 
In addition to loading and processing data as described above, SAC-HOBI Tools 

provides tools for easy charting of both primary and derived data.  Details are explained 
in section 6. 

1.4 SAC-HOBI Tools Files 
SAC-HOBI Tools consists of two main parts: 
• The add-in file “SAC-HOBI Tools.XLA”, which contains most of the 

executable code, and 
• The workbook template “SAC-HOBI Tools.XLT”, which contains pre-defined 

worksheets and support code to hold the loaded and processed data.  The setup 
of this workbook is described in section 3. 

A third file, “Install SAC-HOBI Tools.XLS” assists with installation (see section 
2.3) but is not strictly required.  
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2 INSTALLATION 
2.1 System Requirements 

SAC-HOBI Tools requires a minimum of Excel 2002, Windows 2000, and a 
Pentium II-class computer with sufficient resources to support Excel.  The preferred 
configuration is Excel 2003 or better, Windows XP or better, at least 500MB of RAM, 
and a clock speed of at least 1 GHz. 

2.2 Security Settings 
Because SAC-HOBI Tools contains executable programs that run within Excel, 

Excel may present warnings or even disable some features, depending on its security 
settings.  To view and change Excel’s security settings, select Macro->Security… from the 
Tools menu.  We recommend a security setting of Medium.  If the level is set above 
Medium, you must use the Manual Installation procedure shown in section 2.4, and some 
features may be disabled. 

2.3 Automatic Installation 
This procedure requires Excel’s security level to be Medium or lower (see above).   
First, copy the following files to a directory on your computer.  If you later move 

these files to a different directory, you will need to run the installation again. 
• “SAC-HOBI Tools.xla” 
• “SAC-HOBI Tools.xlt” 
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• “Install SAC-HOBI Tools.xls” 
Double-click on the file “Install SAC-HOBI Tools.xls”.  If Excel displays a message 
warning that the file contains macros, click Enable Macros:

When asked if the file should be installed, click Yes.
A toolbar like the one shown below should then appear in the Excel window. 

If the tool bar does not appear, pull down the View menu and look for the SAC-HOBI Tools 
item.  If it appears without a check mark next to it, select it and the toolbar should appear. 

2.4 Manual Installation  
Use this procedure if your Excel security setting is too high to permit the automatic 

procedure described above.  Note however that a high security setting may also block 
some features of the software, and of workbooks you create with the Add-In. 

• Start Excel 
• Select Macro->Security… from the Tools menu. 
• On the “Trusted Publishers” tab (if it is present), select “Trust all installed add-

ins and templates”.  Click OK.
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• Select Add-ins… from the Tools menu.  If this command is disabled and there are 
no workbooks open in Excel, select New from the File menu, and open a blank 
workbook.  Then select Add-ins… from the Tools menu. 

• Click Browse… 
• Navigate to the directory containing the add-in files, and select the file “SAC-

HOBI Tools.xla”. 
• Excel may ask whether you wish to copy the file to the Add-ins folder.  Click 

No.

• The file you selected should now appear in the add-ins list, with a checkmark.  
Click OK.
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You should see a dialog announcing the presence of the Add-in, and its toolbar should 
appear.  If you do not see the tool bar, select Toolbars->SAC-HOBI Tools from the View menu. 

2.5 Reversing Installation 
Once you have installed the Add-In, it will automatically load every time you start 

Excel, unless you move or rename the Add-In file.  To uninstall the Add-in, open the 
Add-Ins dialog box as described above, and uncheck Sac-Hobi Tools.
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3 WORKBOOK STRUCTURE 
The template file “SAC-HOBI Tools.xlt” contains a number of worksheets set up 

specifically for the HydroDAS data, as well a various features that are not visible to the 
user but facilitate the handling of HydroDAS data.  These include specially named cells 
and ranges of cells, hidden cells and sheets, and executable code.  Because of the 
executable code, each time you open a file generated from this template Excel may 
present a warning that it contains macros.  It is safe to enable these macros. 

The workbook template includes 20 predefined worksheets.  These are divided into 
categories indicated by the shading of their tabs at the bottom of the Excel window: 

Blue shading indicates information that summarizes or controls other sheets.  
Yellow indicates primary data from individual instrument channels, and green indicates 
data derived from the primary data. 

3.1 Summary Sheet 
The “Summary” sheet holds information about loaded data: 
• A list of files from which data have been loaded, and the number of samples in 

each (Figure 1).  If the data were loaded from raw files, the “.OUT” file 
extension is replaced with an asterisk (“*”). 

• The serial numbers and channel identifications of the HydroRads whose data 
have been loaded (Figure 2). 

• The array of wavelength bands applied to the data. 
These tables all filled in automatically during the loading process and should not 
normally be changed by a user. 

Figure 1.  File List 
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Figure 2.  Instrument List—yellow highlighting indicates a mismatch between the 
calibration file and the instrument serial number.

3.2 Primary Data Sheets 
The eight sheets with yellow-shaded tabs hold data loaded from the seven 

HydroRad channels and the fluorometer, and are named accordingly.  For example the 
first sheet holds Es (surface irradiance) data, from HydroRad #1. 

In all these sheets, each line of data represents one sample (with averaging applied, 
if any).  Each line starts with a sample sequence number, and the date and time the 
sample were recorded, then various housekeeping data, then the primary spectral data for 
the channel.  Because Excel is limited to 255 columns in each worksheet and each 
spectral band occupies one column, the number of spectral bands in each sample is 
limited to about 230.  SAC-HOBI Tools permits you to define as many bands as will fit 
within Excel’s column limit.  Excel can accommodate over 65,000 rows of data, 
permitting display of very long time series. 

3.3 Params Sheet 
This worksheet holds various parameters that are used during calculation of the 

derived data.  These are described in further detail in section 5. 

3.4 Derived Data Sheets 
The 10 sheets with green-shaded tabs hold data derived from the primary data.  

These are similar in format to the primary data sheets, with each line representing one 
sample in time, and the spectral data presented with one column per spectral band. 

Unlike the primary data sheets, these sheets also contain formulas that are used for 
derivation of the secondary data.  These are described further in section 5. 

3.5 Modifying Workbooks 
You are free to add any number of worksheets and charts to workbooks created by 

SAC-HOBI Tools, and generally use all the normal Excel features to process and display.  
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However you should avoid the following changes which could interfere with the 
functions of SAC-HOBI Tools. 

• Do not change the names of any of the predefined worksheets. 
• Do not change the sequence of the predefined worksheets, or insert new sheets 

between them. 
• Do not delete or change the names of any named cells or formulas. 

3.6 Modifying the Workbook Template 
If you prefer to change the format of all new workbooks you create with SAC-

HOBI Tools, you can modify the template file (“SAC-HOBI Tools.xlt”).  However you 
should first create a backup copy of the file in case you accidentally make a change that 
interferes with SAC-HOBI Tools functions.  You must also obey the restrictions listed in 
section 3.5. 
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4 LOADING AND PROCESSING DATA 
4.1 Loading Data Processed by the HydroDAS  

The Load Processed Files… command on the SAC-HOBI Tools toolbar loads files 
containing binary packets generated by the HydroDAS’s processing firmware. 

Suitable files may be received via the satellite transceiver or USB offload from the 
HydroDAS’s hard disk.  Files received via satellite may contain text messages and other 
characters that are not part of the HydroDAS format, but the SAC-HOBI Tools will 
ignore these and find any properly-formatted binary packets in the file. 

The command first presents a standard Windows file selection dialog box.  You 
may select any number of files by using the control or shift keys in combination with the 
mouse.  When you the click OK, the program will scan each file for HydroDAS data 
packets.  The name of each file scanned, and the number of packets it contained, will be 
listed on the summary sheet.  Note that it is possible for you to select files of any type, 
even those that do not actually contain appropriate data.  In that case the file names will 
still be listed, but their sample counts will be zero. 

If a SAC-HOBI workbook is already open and active when you select files to load, 
you will be presented with the option to either append the files to the open workbook, or 
to create a new workbook from the template. 

If you choose to append data to an existing workbook, the spectral bands of the 
data sets must exactly match each other.  The software will check this and will not load 
the data if the bands do not match. 
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4.2 Loading and Processing Raw Data 

The Load & Process Raw Files… command duplicates the processing performed by the 
HydroDAS firmware, with a  few enhancements.  This command presents the dialog box 
shown below, in which you set the following parameters: 

• Spectral bands, 
• Maximum tilt, 
• HydroRad calibration files, 
• Source files, and 
• Destination. 

4.2.1 Spectral Bands 
Data are processed into the set of spectral bands you select in this dialog box.  

Whereas the HydroDAS firmware is limited to a maximum of 50 bands, SAC-HOBI 
Tools allows up to 230 bands (limited by the number of columns allowed by Excel).  This 
allows, for example, placing bands every 2 nm from 350 to 800 nm, or every 2.5 nm from 
350 to 850 nm, for full hyperspectral analysis. 
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To define the band set to be used, you can: 
• Designate the first and last band centers, and a regular band spacing, then click 

Calculate to produce a set of uniformly-spaced, constant-width bands; 
• Click From Workbook to use the same band set as the currently active workbook 

(this button is enabled only if a suitable workbook is active); 
• Click From File… to load a band set from a file on your computer; or 
• Enter an arbitrary set of bands one at a time, by entering the center wavelength 

and band width, then clicking Add Band, for each. 
To save the currently displayed set of bands to a file for later use, click Save to File…  

To remove bands from the list, select them by clicking on them in the list (using the 
mouse in conjunction with the control or shift key to select multiple bands), then click 
Delete Selected Bands.

Note that if you wish to load new data into an existing workbook that already 
contains data, the band sets must match.  To ensure they match, click From Workbook to 
load them from the existing workbook. 

4.2.2 Maximum Tilt 
You can enter a separate maximum tilt angle (in degrees) for each of the seven 

radiometric measurement channels.  Spectra collected when the buoy tilt exceeds their 
corresponding maximum value will be excluded from the averaged output.  To include all 
spectra, set the maximum tilt to 45 or higher. 

4.2.3 Calibration Files 
Each of the four HydroRads requires a calibration file containing coefficients for 

converting its raw data to radiometric units.  You must ensure the calibration files are 
assigned to the correct instruments.  If the software detects a mismatch between the 
instrument serial number and serial number stored in the calibration file, it will process 
the data but set a quality control flag in the loaded data.  For details about quality control 
flags, see section 4.3. 

4.2.4 Source Files and Directory 
The Select Files… button presents a standard Windows open file dialog box, in which 

you can select an arbitrary set of files to process (use the control and/or shift keys in 
conjunction with the mouse to select multiple files).  The files you select, and the 
directory holding them, appear in the Processing section of the Load & Process dialog box. 
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4.3 Viewing Data Worksheets 

4.3.1 Missing Values 
If no processed spectra are available from a particular sample, the cells 

corresponding to that sample will be left blank and shaded gray.  This may result from 
transient problems, such as data transmission errors, or from normal events such high tilt 
values that exclude all spectra from the averaged data.  That is most likely at times when 
light levels are low, leading to long integration times.  This in turn results in fewer 
spectra per sample, while also increasing the probability that an individual spectrum will 
be influenced by buoy motion and excluded because of tilt. 

4.3.2 QC Flags 
Each of the primary data worksheets has a column for QC flags, and if any are set 

they are highlighted as shown below. 

A “cal” flag will appear if instrument serial number does not match the serial 
number in the calibration file used for processing it.  Note that the instrument list on the 
Summary worksheet will also highlight discrepancies between calibration file names and 
instrument serial numbers (section 3.1). 

The “high” flag will be set if an instrument’s peak spectral readings are higher than 
another instrument at a shallower depth.  Since the light level normally decrease at deeper 
depths, readings that are consistently too high may indicate a malfunction in one of the 
instruments, or a problem in the positioning of one of the light collectors.  Occasional 
momentary high signal levels may be triggered by normal phenomena such as wave 
focusing.  
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5 SECONDARY PROCESSING: CALCULATING 
DERIVED PARAMETERS 

After the primary data worksheets are loaded with processed data, either directly 
from HydroDAS files or processed from raw files, the secondary parameters are 
automatically derived from them and placed in their own worksheets. 

Some of these parameters are the subject of ongoing research, and will certainly 
require fine-tuning as data are accumulated over the life of the system.  In order to allow 
SAC users to easily modify the algorithms used for this processing, they are expressed as 
normal Excel formulas in the derived parameter spreadsheets.  Some are also supported 
by input parameters on the Params sheet. 

We strongly recommend backing up the template file (“SAC-HOBI Tools.xlt”) 
before making any changes to it. 

5.1 Entering Algorithm Formulas 
Each formula is entered in one key cell on the applicable spreadsheet of the 

workbook template.  During the calculation process (triggered either by the loading of 
data, or by the Recalculate button), this formula is automatically copied throughout the full 
range of cells to which it applies. 

The cells holding the formulas are highlighted with yellow, and on most sheets are 
in the column initially labeled “Spectral Data”.  For example: 

Here the value of the cell is “#DIV/0!”.  This is normal in this case because no data have 
been loaded.  The formula for calculating Remote Sensing Reflectance, RRS, is shown 
above in the formula bar: 

=Lw!D2/Es!S2 
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Lw!D2 refers to the first cell containing spectral data on the Lw (water-leaving radiance) 
sheet.  Similarly, Es!S2 is the first spectral cell on the Es (downwelling surface 
irradiance) sheet.  This implements the definition of Remote Sensing Reflectance, 
 RRS(λ) = Lw(λ) / Ed(0+, λ)

5.2 Entering Parameters 
Some algorithms, particularly the normalized water-leaving radiance, are 

sufficiently complex that, for convenience, their key parameters are entered separately 
from the equations.  These are gathered on the Params worksheet as shown below.  Details 
of this worksheet will be explained along with the individual parameters. 

5.3 Initial Algorithms 

5.3.1 Downwelling diffuse attenuation coefficients 
Analytic equation: 

 Kd(λ) = ln[Ed(z1, λ) / Ed(z2, λ)] / (z2 – z1)
where zi is the depth of sensor i.

Since the system measures Ed(z, λ) at three depths, (z1, z2, z3), there will be three 
computations of Kd, corresponding to the depth combinations (z1, z2), (z2, z3), (z1, z3).  The 
corresponding Excel equations are 

 =LN('Ed1'!S2/'Ed2'!S2)/('Ed2'!$N2-'Ed1'!$N2) 
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 =LN('Ed2'!S2/'Ed3'!S2)/('Ed3'!$N2-'Ed2'!$N2) 
 =LN('Ed1'!S2/'Ed3'!S2)/('Ed2'!$N3-'Ed1'!$N1) 

Note that the references to column N on the Ed sheets, which holds the depth values, are 
preceded by “$”, indicating absolute references.  The other references are relative. 

5.3.2 Upwelling radiance attenuation coefficients 
KLu(λ) = ln[Lu(z1, λ) / Lu(z2, λ)] / (z2 – z1)
Similarly to Kd, we use measurements of Lu at three depths to calculate three KLu 

values: 
=LN(Lu1!S2/Lu2!S2)/(Lu2!$N2-Lu1!$N2) 
=LN(Lu2!S2/Lu3!S2)/(Lu3!$N2-Lu2!$N2) 
=LN(Lu1!S2/Lu3!S2)/(Lu3!$N2-Lu1!$N2) 

5.3.3 Water leaving radiance, Lw(λλλλ)
To compute Lw, we must first propagate Lu(z1) to the surface.  To do this, we use 

the computation of KLu measured from Lu(z1) and Lu(z2).  Hence, Lu just below the surface 
is estimated to be: 
 Lu(0-) = Lu(z1) exp(KLu, z1). 
Then we propagate Lu(0-) through the air-water interface to obtain Lw:

Lw(λ) = Lu(0-) t / n2

In Excel, 
 =Lu1!S2*EXP(Klu12!D2*Lu1!$N2)*water_air_transmission/(index_of_refraction)^2 

The symbolic names “water_air_transmission” and “index_of_refraction” refer to values 
entered in the appropriately labeled cells on the Params worksheet.  

5.4 Remote sensing reflectance 
 RRS(λ) = Lw(λ) / Ed(0+, λ)
In Excel, 

 =Lw!D2/Es!S2 

5.5 Normalized water-leaving radiance 
 LwN(λ) = Lw(λ) exp{ [τr(λ)/2 + τ0z(λ)] [1/cosθ0] } / cosθ0

where θ0 is the solar elevation angle and τr(λ) and τ0z(λ) are atmospheric transmission 
parameters.  This equation involves a number of supporting parameters. 
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 SAC-HOBI Tools includes a function called SunElevation, for computing the solar 
elevation angle θ0. Sunelevation takes date, time, latitude, longitude and time zone 
arguments.  The latitude, longitude and time zone are entered on the Params worksheet.  
The latitude and longitude are entered in degrees and minutes.  North latitudes are 
entered as positive, South as negative.  East longitudes are entered as positive and West 
as negative.  The time zone is entered as an offset, in hours, from Greenwich Mean Time.  
India’s time zone is +5.5 hours by this measure.  Symbolic names are assigned to these 
parameters in the workbook template, and used in the following Excel equation for the 
sun angle: 

=SunElevation(B2,Latitude_Degrees+Latitude_Minutes/60,Longitude_Degrees+ 
Longitude_Minutes/60,Time_Zone) 

 The spectral quantities τr(λ) and τ0z(λ) must also be entered in the Params sheet, 
in the form of Excel equations.  These equations must be entered in the yellow-
highlighted cells shown below.  

As part of the secondary parameter derivation, this table will be expanded to include the 
complete list of wave bands, with their wavelengths shown in the λ column.  The 
formulas entered in the yellow cells will also be copied so as to complete the table of 
τr(λ) and τ0z(λ) values.  In the delivered template, these cells hold simple formulas that 
are strictly for illustration.  These must be replaced with formulas that are valid for  

Finally, these elements are brought together in the Lnw worksheet, using the 
following Excel formula: 

=Lw!D2*EXP((LOOKUP(E$1,Tau_r_table)/2+LOOKUP(E$1,Tau_0z_table)) 
*(1/COS(D2)))/COS(D2) 

where D2 contains the result of the SunElevation function, E$1 refers to the wavelength, 
and the LOOKUP function is used to find the values of τr(λ) and τ0z(λ) corresponding to 
the wavelength. 

5.6 Chlorophyll concentration 
Various empirical algorithms are used for extracting chlorophyll concentration 

from ocean color data.  We have implemented the following algorithm with the 
expectation that SAC scientists will choose input parameters that are appropriate to their 
deployment location, and possibly modify the equation. 
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C = exp[ A + B Lw(λ1)/Lw(λ2) ]
Some scientists prefer LwN instead of Lw in this formulation.  The wavelengths, λ1 and λ2
and the parameters A and B are entered in the Params worksheet.  The Excel equation we 
have entered in the Chl worksheet is 

=EXP(chl_coeff_A+chl_coeff_B*OFFSET(Lw!D2,0,chl_lambda_1_band) / 
OFFSET(Lw!D2,0,chl_lambda_2_band)). 
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6 CHARTING DATA 

The Chart Data… button opens a dialog box in which you can select any of the 
radiometer channels, and/or derived parameters to plot.  Data can be plotted spectrally or 
as time series. 

6.1 Spectral Charts 
To display spectra, select the Wavelength option for the X Axis.  In this mode you 

will only be able to select spectral quantities to chart, and the Wavelength Bands list will be 
disabled because the entire spectrum will be displayed.  You can select any number of 
parameters to display within one chart.  Of course since they will share one set of axes, 
some combinations of parameters will not be useful. 

After you click Make Chart, the chart will display one spectrum of each of the 
parameters you select.  The spectra represent one sample from the data time series.  
Below the chart, a horizontal scroll bar allows you to select which sample to display, or 
to scan through all the time samples in the dataset.  The sample number and time of the 
currently-displayed sample are shown in the chart legend. 

 By default, the maximum of the Y axis automatically adjusts to the largest 
spectrum displayed, and the minimum is fixed at zero.  However while scanning through 
a large data set with the scroll bar it is useful to be able to freely change between 
automatic and fixed scaling.  While you can change the settings through the normal Excel 
functions, for more rapid control we provide a set of buttons in the upper left corner of 
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spectral plots.  In case the buttons interfere with the graph contents, they can be hidden 
by unchecking Show Buttons above the chart area. 

Hold Max fixes the maximum at its current value. 
Auto Max sets the maximum to automatic (default setting) 
Auto Min sets the minimum to automatic 
Hold Min fixes the minimum at its current value 
Min = 0 fixes the minimum at zero (default setting) 

The default settings can be changed in the chart template (see section 6.4).   

6.2 Time-series Charts 

To display time series, select the Time of Day or Date & Time option.  In Date & Time 
mode, the X axis will display the date.  In Time of Day mode, the x-axis will have a 24-
hour range and if the dataset includes multiple days of data, the days will be overlaid. 
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Time-series charts display the parameters you select throughout the entire time 
range loaded in the present workbook.  They do not include the scroll bar or axis-scaling 
buttons of the spectral charts (because they are not needed). 

6.3 Modifying Charts 
After creating a chart in SAC-HOBI Tools you can use the full capabilities of Excel 

to modify its format, rename it, add or remove data, or delete the chart. 

6.4 Chart Template 
The charts generated by this command are based on a template that is normally 

hidden within the workbook.  To modify the default settings that will be used for future 
charts, for example the font styles of the axes or the position of the legend, you can 
modify this template.  However before making any changes you should make a backup 
copy.  To save a copy with the existing workbook template, 

• Open “SAC-HOBI Tools.xlt” 
• If the ChartTemplate tab is visible, click it to activate the template. 
• If the ChartTemplate tab is not visible, 

o On the Format menu select Sheet->Unhide… 
o Select ChartTemplate in the Unhide dialog box, and click OK.
o Click on the ChartTemplate tab in the workbook 

• On the Edit menu, select Move or Copy Sheet… 
• In the Move or Copy dialog box: 

o select (move to end) under Before sheet 
o check Create a copy 
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o click OK 
This will create a new chart called “ChartTemplate (2)” which will serve as your backup.  
To restore this as the main template, change its name back to “ChartTemplate”.  To 
change the name, right-click on its workbook tab, then select Rename from the popup 
menu. 
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